Save/Load bug?

Everything that does not fit into the catagories below.

Moderators: Moderators, General Forum Moderators

Save/Load bug?

Postby tmcsweeney » Wed Jun 21, 2006 4:22 pm

I encountered a problem recently with my entry for the Eurogramer contest.

Basically I had a finicky, chaotic solution for the level that only just worked (after much random tweaking). But after saving the level and reloading it had ceased to function. It is a chaotic solution, and the results where noticeably different (quite apart from the 'Dillo not ending up in the goal)

Some of the other people on the Eurogamer thread have seen the same thing, and I was wondering if anyone here had similar experiences.
Or am I just a doofus who forgot to save properly?

Is it possible that the save/load process subtly changes the level? (perhaps even the order in which pieces are defined) which in turn subtly changes the results of the physics solver. In normal use it would be unnoticeable, but it certain chaotic edge cases like this it would radically alter the outcome of the level

User avatar
Posts: 48
Joined: Mon May 29, 2006 9:48 am

Postby BFC » Wed Jun 21, 2006 7:10 pm

I've had it where a backup copy of a level worked and the "working" copy did not.

I always make a backup copy of any solution I make that works. That way I don't mess up the level by accident. I have noticed on more than one occasion where my backup copy worked but my normal copy did not. I know I didn't touch the working copy either in this case. I just chalked it up to "maybe I did futz with it and hit save by accident", but perhaps it is slightly buggered?

For now, I'd recomend that people immediately make a backup copy of any working solution. It has saved me in the past.

Contest Legend
Contest Legend
Posts: 257
Joined: Mon May 29, 2006 10:23 pm

Postby Zut » Wed Jun 21, 2006 9:46 pm

I think I have experienced this too. I had a very near the mark solution that invovled tensioned cloth. Sometimes the armadillo would just roll and sometimes it would bounce and fall out. But this change would occur without me altering the level itself at all.

The difference was essentially only very minor, but the result was very different due to the fine tolerance of that solution.
Posts: 14
Joined: Thu Jun 01, 2006 7:33 pm
Location: Sheffield, UK

Postby stig » Wed Jun 21, 2006 11:13 pm

yes I have found that sometimes you can delete a cloth, then
create it again between the same two nodes and it gives a different
result, and every time i delete and recreate i get a new result !!!
I guess its to do with the way numbers are rounded up or down in
the physics equations
User avatar
Posts: 15
Joined: Sun Jun 04, 2006 10:12 am

Postby squint » Fri Jun 23, 2006 12:37 am

I've seen this too. However, I'm pretty sure I've seen it without load/save. I've never been able to reproduce it consistently, but in my head I thought it was to do with using slow motion during the run that worked, and then it doesn't work at full speed.

Given what I know of physics engines, that sounds a bit unlikely, but there we go.
User avatar
Posts: 40
Joined: Tue May 30, 2006 12:09 am

Postby Ogre » Sat Jul 01, 2006 7:53 pm

Along these lines, I have a working solution to this week's contest where I can delete one specific piece, then undo the delete (not replace it, actually undo), and it no longer works.
Contest Winner
Contest Winner
Posts: 117
Joined: Thu Jun 15, 2006 8:51 am

Re: Save/Load bug?

Postby Tuxi » Tue Aug 19, 2008 7:46 pm

I've had these bugs in my two FIRST levels... Sooo Im pretty pissed off with this game now.
Posts: 7
Joined: Mon Aug 18, 2008 7:49 pm

Re: Save/Load bug?

Postby Tuxi » Tue Aug 19, 2008 10:15 pm

SOLVED! I created some random rubber plates in the map, run the map, doesnt work yet. Then just undo the rubber plates and the map should work normally after that. But still, this is annoying bug, isnt there any way fixing it? :(
Posts: 7
Joined: Mon Aug 18, 2008 7:49 pm

Return to General

Who is online

Users browsing this forum: No registered users and 1 guest